Products Affected: All Wave IP versions, Recording Archive Server
Problem
The Wave IP cannot archive calls. The Wave IP retains the old name of a Recording Archive Server (RAS) in the Recordings>Archive settings of User/Group Management and it cannot be replaced.
Cause
RAS is renamed or replaced without first removing the Wave IP from the settings on the RAS. This leaves the connection in the Wave IP database.
Symptoms
The old RAS name appears in the Archiving Server field on the Wave.
Solution
- Login to the system desktop (Login to System Desktop).
- Clear the DBRegistry table’s value for \Artisoft\VoiceMail\ArchiveServer by doing the following:
- Run SQL Server Management Studio Express from Start > All Programs > Microsoft SQL Server and connect to the local database.
- Click on the New Query button.
- From the database dropdown select GDR.
- Paste UPDATE DBRegistry SET Value = '' WHERE Name = '\Artisoft\VoiceMail\ArchiveServer' in the right-hand pane and click Execute.
- Close and Reopen TVAdmin to verify the change has taken effect.
The ‘Archiving Server’ name setting under Tools > System Settings > Recordings > System Call Recording should now be blank allowing an Archive Recording Server to connect to and archive recordings.
Alternatively use the attached script ClearArchivingServerName.zip.