Wave 7.0: Global Admin applets using RDP

Issue:

Starting in Wave 7.0, when you are logged into the Global Administrator web page and attempt to launch applets that initiate a Remote Desktop connection, e.g. User/Group Management, instead of getting the specific application launched, you instead are logged into a generic Windows desktop.

Cause:

This issue stems from a change to the way Remote Desktop for Administration changed between Windows Server 2003 and Windows Server 2008. Launching individual applications in these instances is no longer honored.

NOTE: For Wave 5.0 & 6.0, which were based on Windows Server 2008, Vertical implemented a workaround that is no longer acceptable on Windows Server 2016.

Workaround:

The best practice / workaround for this issue is to launch a Remote Desktop session to the Wave and from there open the applications directly, including the Global Administrator web page via IE. User/Group Management is TVAdmin; most of the other applets are self-explanatory.

The reasons this is best practice:

  • Some users would launch a Remote Desktop session anyways, then login to the Global Administrator web page and there launch User/Group Management, thereby tying up two Remote Desktop sessions where only one is required.
  • Launching IE, on a user’s PC, is no longer necessary.
  • Logging into Global Administrator web page via the Remote Desktop session ensures that the Wave’s version of Java is used and thereby accessing the Wave would not require Java installed on the user’s PC.