Products Affected: Wave 5.0
Problem
Using the Vertical OpenVPN image and Wave 5.0, the first time OpenVPN configuration is enabled in the Wave IP, all of the configuration steps do not occur and the OpenVPN server does not connect phones. This currently happens consistently on the first setup of OpenVPN in the Off Wave mode.
Cause
Engineering is determining the cause and a fix may be issued later to address the problem.
Symptoms
This problem occurs the first time a Wave is set to Enable VPN Support and Vertical OpenVPN: Off Wave. All settings do not apply to the OpenVPN server. It is possible to verify this problem by logging on to the OpenVPN server (for instructions on how to log on to OpenVPN server see Set OpenVPN Server IP Address).
- On the desktop of OpenVPN server, there is a Computer icon. Double-click on it.
- A window appears. Double-click Filesystem.
- Double-click on the etc folder.
- Scroll down in the window to find the OpenVPN folder and click on it.
If the folder has been properly configured then a file named auth.py should appear in the folder. If there is no such file, then automatic configuration did not complete and the Solution should be applied.
Solution
The simplest solution is to uncheck the Enable VPN Support box and click Apply. Then check the Enable VPN Support button and Apply again. Recycling the setting like this should cause the OpenVPN server to be fully configured (verify by check the Auth.Py file is added.)
If phones are already configured, then they will need to be defaulted (see Default a 9800 Series Phone) and have their configuration redeployed from the Wave (as the recycle step above generates a new Certificate).